OptParse

Do obsługi parametrów wejściowych do skryptu w Ruby jest biblioteka OptParse . Aby jej użyć, wystarczy dołączyć ja poprzez: require 'optparse'. Nie jest ona jednak idealna – brak jej sensownej obsługi parametrów wymaganych/opcjonalnych, dodatkowo czasem kod nadmiernie rozrasta się. Plusem jest obecna dokumentacja wraz z przykładami i brak konieczności instalacji.

Przydatny wpis? Postaw mi kawę :)